Welcome, Guest

Author Topic: I'm Back!!  (Read 1531 times)

Offline celica842

  • Full Member
  • ***
  • Posts: 266
    • View Profile
Re: I'm Back!!
« Reply #30 on: Apr 02, 2020, 02:54:54 pm »
My edu has two plugs went ahead and ordered a vacuum dizzy.. Hopefully be here tomorrow. Thanks for all the help!!!

Offline danf

  • Senior Master
  • ******
  • Posts: 3,605
    • View Profile
Re: I'm Back!!
« Reply #31 on: Apr 02, 2020, 05:00:10 pm »
Make sure you compare the two distributors to make sure they're the same length, and critically, it seats in the same place.
SELECT celica FROM toyota WHERE year<=1985;

1985 GT-S
-Rebuilt engine: bored .020 over, oversize valves, new cam
-Thorley header w/heated O2 sensor at collector & all new exhaust
-Impact6 strut bar
-3.9LSD rearend, which is now slipping
-Lots of bodywork and new paint!
-New cd player to cover up all those squeaks and rattles
-JK short-throw shifter


Offline ozzie

  • Senior Master
  • ******
  • Posts: 9,811
    • View Profile
Re: I'm Back!!
« Reply #32 on: Apr 02, 2020, 11:31:02 pm »
The 84 and 85 dizzys are the same length with the same gear size/position, I posted a pic a while back showing it. Mine was actually a '94 distributor, but same diff.
'84 Celica GT - 261k mi

Offline celica842

  • Full Member
  • ***
  • Posts: 266
    • View Profile
Re: I'm Back!!
« Reply #33 on: Apr 03, 2020, 11:16:07 pm »
Got the new dizy in and yes she runs a lot better now just need to finish the exhaust so she has back pressure..oh one last question there are two vacuum nipples in the dizz and I looked up pics and I hooked them up to match the pics I've seen but does it matter which one go gets vacuum all the time? The other port on the throttle body I suspect is only vacuum at wot?

Offline RedCar

  • Full Member
  • ***
  • Posts: 313
    • View Profile
Re: I'm Back!!
« Reply #34 on: Apr 04, 2020, 03:25:32 pm »
Here's the diagram:


I'm trying to figure out what the logic behind the dual diaphragm distributor is...

Here's my guess:
outer diaphragm (main advance port) maintains some advance at idle
inner diaphragm (sub advance port) cancels the vacuum advance whenever throttle opens & centrifugal advance to takes over
83 GT Sport

Offline Teranfirbt

  • Global Moderator
  • Grand Master
  • *******
  • Posts: 24,377
    • View Profile
Re: I'm Back!!
« Reply #35 on: Apr 04, 2020, 06:56:25 pm »
I believe it's a way to prevent the car idling low when the alternator is loaded up. At normal idle it'll pull a few degrees of timing when manifold vacuum is high, but as RPM drops with load increase, it will see less manifold vacuum and increase timing to increase power a bit to maintain idle.
1983 Celica GT-S 2RZ swap: Deered 2014 :(
1986 Tercel 4WD 4AFE Swap: Going strong
1986 MR2: What a beast!
2014 Elantra GT: The reliable one

"Only two things are infinite, the universe and human stupidity, and I'm not sure about the former." ~ Albert Einstein

Offline celica842

  • Full Member
  • ***
  • Posts: 266
    • View Profile
Re: I'm Back!!
« Reply #36 on: Apr 05, 2020, 02:12:53 am »
Awesome I for sure have it hooked up wrong.. I did drive it today and I think I need to readjust the throttle stop and tps under load she's cutting out like she's hitting the fuel cut off but round 1 I adjusted the throttle stop to keep her running now that I have ever thing close to right need to readjust that.. But with any luck she'll be going to the exhaust shop tomorrow I think I got header adjusted where it should clear the steering ill know in the morning.. Maybe I should wait to adjust anything till the exhaust shop is done.

Offline celica842

  • Full Member
  • ***
  • Posts: 266
    • View Profile
Re: I'm Back!!
« Reply #37 on: Apr 12, 2020, 03:04:37 pm »
https://www.facebook.com/100000929636263/posts/3983064745067807/?app=fbl well turns out the lower intake manifold gasket was causing a vacuum leak as well as leaking coolant.. Replaced with a felpro and she runs like she should now. Thank you guys for all the help.. Now off to the exhaust shop and inspection station.

Offline irmicken

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: I'm Back!!
« Reply #38 on: Apr 14, 2020, 09:51:57 am »
Can't wait to see how it turns out.

Offline celica842

  • Full Member
  • ***
  • Posts: 266
    • View Profile
Re: I'm Back!!
« Reply #39 on: Apr 18, 2020, 04:42:04 am »
Well dropped off at the exhaust shop Wednesday got a call she was ready today. Was kinda surprised they went this route but I'm really loving the look and the sound.. I was expecting a regular muffler with a cat but no cat was installed.. still loving it.

Offline celica842

  • Full Member
  • ***
  • Posts: 266
    • View Profile
Re: I'm Back!!
« Reply #40 on: May 04, 2020, 02:52:41 am »
A little update I installed a pke push button remote start system.. and an aftermarket centeral door locks everything went together pretty easy but I'm still working on getting the two to talk I think I found a way but waiting on parts..  I love the unlock and disarm automatically when I walk up and arm and lock when I walk away. I didn't hook up the horn though that would get on my nerves. I did get the chance to take it on the hwy had to travel for work and I found out I have a vibration at 70-75 goes away at 80. Took it to ntb thinking a tire was out of balance said rear ujoint was shot.. well when I put the drive shaft in I felt a tiny bit of play wouldn't say it was shot..but just ordered some ujoints from Rockford part number 430-10 so she's been parked till I can get those in.. not blowing up another rear end.. how ever I do have a question going down the hwy if the rpm is steady like holding 3000 rpm in 5th gear doing 80 my check engine light comes on.. I even tried in city streets if the rpm is constant doesn't matter speed or rpm the light come on soon as I change the rpm goes off nothing is stored.. thought everything was hooked up correctly she runs great. Just wondering why the light comes on and how to correct it.

Offline sirdan

  • Senior Master
  • ******
  • Posts: 6,645
    • View Profile
Re: I'm Back!!
« Reply #41 on: May 04, 2020, 11:55:41 am »
Do you have a heated o2 sensor? usually if you go to a header and use the stock non heated o2 it will throw a code cruising because the sensor gets too cold. Heated o2 sensors are 4 wire if you get one for a 4 runner or pickup that is 4 wire and wire the extra wires for the heater up you should be good to go.
1988 4runner

Offline celica842

  • Full Member
  • ***
  • Posts: 266
    • View Profile
Re: I'm Back!!
« Reply #42 on: May 05, 2020, 04:55:30 pm »
Awesome I will get that done thanks.

Offline celica842

  • Full Member
  • ***
  • Posts: 266
    • View Profile
Re: I'm Back!!
« Reply #43 on: Jun 07, 2020, 04:03:58 am »
Sorry been awhile drove the Celica for a few weeks and discovered I got a rear main seal leaking and I lost my speedometer (the clip on the drive gear on the shaft broke) I did get another one but decided it was time for paint and body work the cheap maco paint job the previous owner had done.. going to go to a metallic blue... Addressing the rust in the hatch is the hardest thing thus far..

Offline celica842

  • Full Member
  • ***
  • Posts: 266
    • View Profile
Re: I'm Back!!
« Reply #44 on: Jun 07, 2020, 04:07:22 am »
More pics